Buying a Twingo GT

Help Support Twingo Forum:

Didge3

Well-known member
Joined
Dec 27, 2013
Messages
74
Reaction score
0
Well I picked up my Twingo GT today :D
Pleasant drive out of town, got onto some lanes (although unfamiliar, the garage is not local) and the Twingo quickly put me in my place when going round a corner I planted my foot and the turbo just happened to kick in and cause the car to fidget around.
The rest of my drive was mainly motorway but can't really complain, dealt with the miles well, nothing to complain about. After a hour the CD I'd burnt to keep my entertained for the journey stopped playing and the screen just displayed 'TOO HOT' and switched to the radio which was a bit funny but it played the disc again about 5 minutes later.
I have two questions as of yet,
1. Sometimes I can't get the ignition key in very easily, it goes in about half way and then stops and I have to try again, but other times it's perfectly fine :?
2. Where the millage is displayed beneath the speed, shortly after I start the engine it disappears and changes to how many miles till its next service. Can you make it not do this and just show the cars millage or is this fixed?
 

LC

Well-known member
Joined
Sep 16, 2013
Messages
828
Reaction score
0
Didge3":18pcdlx8 said:
Well I picked up my Twingo GT today :D
Pleasant drive out of town, got onto some lanes (although unfamiliar, the garage is not local) and the Twingo quickly put me in my place when going round a corner I planted my foot and the turbo just happened to kick in and cause the car to fidget around.
The rest of my drive was mainly motorway but can't really complain, dealt with the miles well, nothing to complain about. After a hour the CD I'd burnt to keep my entertained for the journey stopped playing and the screen just displayed 'TOO HOT' and switched to the radio which was a bit funny but it played the disc again about 5 minutes later.
I have two questions as of yet,
1. Sometimes I can't get the ignition key in very easily, it goes in about half way and then stops and I have to try again, but other times it's perfectly fine :?
2. Where the millage is displayed beneath the speed, shortly after I start the engine it disappears and changes to how many miles till its next service. Can you make it not do this and just show the cars millage or is this fixed?

2. There's a button on the end of the wiper stalk changes it through temp/mileage/trip mileage/miles till service
 

Didge3

Well-known member
Joined
Dec 27, 2013
Messages
74
Reaction score
0
Thanks again, noticed there was also a button on the end of the indicator stalk, thought wonder what that does..... oh.

I'll give the WD40 a go.
 

Didge3

Well-known member
Joined
Dec 27, 2013
Messages
74
Reaction score
0
mikehealy5":i6ppj91n said:
remember to post some pictures when you get chance. where are you based?
I'll start a new thread with pictures and some of my plans for the car tomorrow if theres ever a gap in the rain... :roll:
Based down in Hampshire/Kent.
 

Didge3

Well-known member
Joined
Dec 27, 2013
Messages
74
Reaction score
0
I got some pictures up and started a new thread to keep things tidy, here.
 
Top